Aviso InsecurePlatformWarning ao verificar a lista de pacotes no pip

Hoje fui verificar se havia algum pacote do pip que necessitasse de atualização. Só que ao executar o comando abaixo:

pip list -o

recebi a seguinte mensagem de aviso:

C:\Python27\lib\site-packages\pip\_vendor\requests\packages\urllib3\util\ssl_.py:79: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning

De acordo com o link no aviso[1] versões do Python abaixo da 2.7.9 (estou usando a 2.7.8) têm alguma restrição ao módulo ssl e a recomendação é a atualização do Python🙂 .

Feito a atualização tudo volta ao normal.

[1] https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning

Sobre Fábio Medeiros

Meu nome é Fábio Medeiros. Cearense de nascença e com muito orgulho (daí o nome do blog, uma referência à minha terra). Sou formado em Tecnologia em Telemática, pelo CEFET-CE. Escrevi alguns artigos sobre programação JavaME e dispositivos portáteis (PDA) para a revista WebMobile.
Esse post foi publicado em Soluções e marcado , . Guardar link permanente.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s